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:How do I fix copy and paste issues from a Windows ECS instance using Remote Desktop Connection?

Last Updated:Aug 08, 2025

This topic describes how to resolve the issue where you cannot copy and paste content when you connect to a Windows Elastic Compute Service (ECS) instance using Remote Desktop Connection.

Problem description

After you connect to a Windows ECS instance using Remote Desktop Connection, you cannot copy content from the instance and paste it to your local computer.

Cause

The rdpclip.exe process is not running correctly on the Windows ECS instance.

Note

rdpclip is a Remote Desktop component used for copying and pasting content during a remote session. If the rdpclip.exe process is not running correctly on the instance, you cannot copy content from the instance to your local computer.

Solution

To resolve copy and paste issues on a Windows ECS instance, restart the rdpclip.exe process on the instance.

Perform the following steps to fix the issue:

  1. On your local computer, click Start > Run. In the Run dialog box, enter mstsc and click OK. The Remote Desktop Connection window appears.

  2. Click Show Options. On the Local Resources tab, select Clipboard under Local devices and resources. Click More, select Drives, and then click OK.

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  3. Log on to the Windows instance using Remote Desktop Connection and open Task Manager. On the Details tab, select the rdpclip.exe process and click End Task.

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  4. Click Start > Run again. In the Run dialog box, enter rdpclip.exe and click OK to restart the program.

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  5. Verify that the copy and paste function is working.