This topic describes how to resolve the issue that the "Allow Remote Assistance connections to this computer" option in Remote Assistance cannot be selected for an Elastic Compute Service (ECS) instance that runs Windows Server 2008 or 2012.
Problem description
When you enable Remote Assistance for an instance that runs Windows Server 2008 or 2012, the "Allow Remote Assistance connections to this computer" option is grayed out and cannot be selected.
Cause
The Remote Assistance feature is not installed on the instance that runs Windows Server 2008 or 2012.
Solutions
This section describes the solutions to the preceding issue in Windows Server 2008 and 2012. Select a solution based on the actual operating system version.
Windows Server 2008
Connect to the instance.
For more information, see Methods for connecting to an ECS instance.
Choose Start > Control Panel > Administrative Tool > Server Manager > Features and click Add Features.
In the features list, find and select Remote Assistance, and then click Next.
Windows Server 2012
Connect to the instance.
For more information, see Methods for connecting to an ECS instance.
In the Windows taskbar, select Server Manager.
In the Server Manager window, select Add roles and features.
In the Add Roles and Features Wizard window, click Next until the Features list appears, select Remote Assistance, and then click Next.