This topic describes how to resolve the issue that you cannot stay connected to a Windows instance by using Remote Desktop.
Problem description
After you use Remote Desktop on your computer to connect to a Windows instance, if you do not perform operations on the instance for 1 to 2 minutes, you are disconnected from the instance and cannot connect to the instance again.
Cause
The startup type of the Routing and Remote Access service is set to Automatic (Delayed Start) on the Windows instance.
When the startup type of a service is set to Automatic (Delayed Start), Windows delays launching it until the operating system has fully initialized. This helps resolve the issue that low-configuration computers slowly start or respond when a greater-than-expected number of services start on system startup. When the startup type of the Routing and Remote Access
service is set to Automatic (Delayed Start) on an instance, the Remote Desktop connection to the instance is closed in a brief period of time after you connect to the instance by using Remote Desktop.
Solution
Connect to the Windows instance by using Virtual Network Computing (VNC).
For more information, see Connect to a Windows instance by using a password.
Click the
icon, open Control Panel, and then find System and Security.
In the Control Panel window, click System and Security and then click Administrative Tools. In the Administrative Tools window, double-click Services.
In the Services dialog box, double-click Routing and Remote Access. The Routing and Remote Access Properties (Local Computer) window appears.
Select Disabled from the Startup type: drop-down list and click OK.